Sunday, November 11, 2007

Easy Codec Install for Gutsy

This simple howto installs the most common restricted codecs in Gutsy, allowing you to play mp3, aac, DVD ,mp4, avi, wmv and many more formats. It also installs the codecs for ripping mp3 using the lame encoder in Soundjuicer and making CDs from mp3s in K3b.

This is rewrite of a howto that I did for Feisty and it just needed a little touch up for Gutsy.

In a terminal type:
sudo apt-get install gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly gstreamer0.10-ffmpeg libxine1-ffmpeg libdvdread3

In order to play copyrighted DVDs, you need to install the libdvdcss2 package. To do this you need to install the Medibuntu repository. You can find my howto here.

Once you install the Medibuntu repository, in a terminal type:
sudo apt-get install libdvdcss2
edited by pHreaksYcle

8 comments:

rollerskatejamms said...

Dude, ubuntu restricted extras metapackage.

redDEAD said...

rollerskatejams
thats a great starting point but this howto includes a couple of other things most users will need.

Luobotou said...

redDEAD - you are so on the mark!

restricted extras only covers the beginning.

-jazzybob and his UBUNTU 1501

Alexey Zavizionov said...

What about *.mkv video files format?

redDEAD said...

mkv should work

Alexey Zavizionov said...

Which video player did you try to open .mkv video?

redDEAD said...

totem

Drew said...

If anyone can explain the line from top right to bottom left, please do tell. There is a thread about it here:
http://ubuntuforums.org/showthread.php?t=489743