Thursday, December 20, 2007

Dell's Inspiron 1501 Service Manual

This is a direct link to Dell's Documentation Website

Inside you'll find complete guides for the:
Optical Drive
Hard Drive
Memory Module
Modem
Mini-Card
Hinge Cover
Keyboard
Display Assembly
Palm Rest
Coin-Cell Battery
Speakers
Processor Thermal-Cooling Assembly
Processor Module
Fan
ExpressCard/Hard-Drive Bay Assembly
System Board
Battery Latch Assembly
Flashing the BIOS
Pin Assignments for I/O Connectors

I was sent this a long time ago, It's about time I posted it.

33 comments:

jim said...

There's instructions there for replacing the processor module. Does that mean the CPU is user-replaceable? I'd love to crank this thing up to a dual-core config from the Sempron I have now.

redDEAD said...

jim,

yeah its not easy to replace laptop processors but its not to hard either. just have to remember not to put too hot of a processor in a laptop. It was only built to cool certain processors.

jim said...

Hmm. Looking at what's available online, I see a few Turion 64 X2's, but they're all rated at 35W - including the ones that Wikipedia says that the Inspiron 1501 was shipped with. I looked on Dell's website, but apparently the 1501 has since been discontinued, so I can't find anything on that.

How would I know if the Inspiron 1501 can take a 35W processor without trying after I buy?

Christopher said...

Actually, these are user-serviceable. The CPU is in a zif socket (S1) and as far as is available now, you can put up to a Turion 64 X2 2.3 Ghz in there. I think that's the TL-66 but you'd have to check.

Guram said...

It's not hard to swap CPU-s. There is a manual how to take this notebook apart. I have TL-50 33W now. I want to upgrade to TL-66 35W. I think this CPUs are interchangeable. You can upgrade to any CPU from Sempron to TL-66. It will only affect you PC's temps and battery performance also, but it's normal...

Joao S. said...

I've noticed that u are using 192 MB for video card, how did u change that?

redDEAD said...

Joao S.

I have 1.5 GB of RAM, the more RAM you add the more RAM is used for shared memory.

Roberto Román said...

Hi,

I have an Inspiron 1501 with a Sempron processor, I'd like to change my processor for a dual core.

I ain't found too many information about the CPU supported by my main board, I know I could put a TL50 or a TL56, but I'd like to install something faster, are you certain that a TL60 or a TL66 would run on it at their full power?

Thanks

gurz said...

There's no reason why it shouldn't WORK. Only tl-66 is higher clocked an it is hotter than previous tl-60. I recommend you to buy tl-60 it's safe. Good luck.

Andrew said...

The 1501 is a pain to take apart, but using this service manual i managed to swap out my 2.0GHz single core CPU with a TL-60 Turion X2 (2.0GHz per core) and it worked an absolute treat.

Cleaning out the heatsink and adding new thermal paste also means that this new CPU is cooled effectively.

now im waiting on a new 320GB hard drive and thinking about bumping it up to 2GB RAM

Ubuntu 8.04 here I come!

neo said...

huy ,,
im using dell inspiron 1501 sempron 512 mb ram (4200s) ..now i want to upgrade it to 1gb !! ?? if i bought the ram 5300s will it cause any confliction ??? when i searched net i found both have different speed 4200s is 400mHz and 5200s is 667mhz ... whats the ram speed supported by the board ??? i cant find the ram speed from the system ..hopes that u will give me a final asnwer !!! all the wishes to this blog !!

redDEAD said...

neo,

you have to call dell, they are the only source who will be able to give you a definitive answer on what ram your specific motherboard can take.

sorry

neo said...

thanks man as always!!
thanks for the support !!accrdng to my knowledge in desktops generally the ram speed cant make a confliction if the higher capacity ram has higher speed !! but i dont know abt what that of case in laptop ..i found this message from dell now !! i posting it here if it helps someone with the same doubt !!
it shows 5300s will support dell 1501 ..but dnt know if it support with a 4200s ram...
http://search.ap.dell.com/results.aspx?s=dhs&c=in&l=en&cs=indhs1&k=dell+1501+memory&cat=all&x=0&y=0

the problem is that i dont want to call dell and waste some cash for that ..

Roberto Román said...

Neo,
You could search a Kingston memory. I have an Inspiron 1501 with a Sempron CPU, last year I bought there 1 Gb, it's not expensive (less than US$ 40) and works great.
You can do a manufacturer & model search on their site and you'll find it.
Roberto

neo said...

wishing the best again to all

huy guys ,,,

my laptop palm restng part became dirtly after 1year use ..(may be due to te sweat frm my hand )
and i tried to clean with my AXE spray (thought it will do as it clean dirty cd's),,
and i tested on a small portion ....,the silver coating is lost revealing it white body ...

now i think to put some sticker over the dirtly brown part...

but what i want to knw is that is there any option to change my laptop body case ?? is it available .... or i have to do soem spary paintng over the body ,,,if i choosed to spray paint ,,,will it harm my laptop ??/

hopes that someone familiar withe my probelm will reply ,,sorry for my ENGLISHHHHHHHHH,,,thanks guys for the support !!!

Peter said...

Any Turion socket s1 35w will be usable. Replacing is not hard but do remember heat transfer paste otherwise you will have problems.

neo said...

Support needed for battery charging problem

huy ,,im having dell inspiron 1501 sempron (i mentioned this in my ealier posts )..i have a problem regarding the battery changing !! even if its "plugged in" it doesnot show more than 24%-26% battery power ...
i bought lap on 2007 jan and since then i use most time by direct power supply without removing the battery ...but 2 days before i have to use it in battery mode .. ,,so after sometime my battery got discharged and system went to standby mode ..i remember i got the critical alarm signal only 3 times after buying ... ..i use my lap normally at home so i never used the battery power more ...

but now the battery is not charging more that 26% ...i tried to run in battery mode and its working by discharging at normal rate ...but when i tried to charge it charged normally up to 26% and after that the power indicator doesn't show any increase ...i charged for one full night ..but no change !! i checked the led in battery also ..it also blink 2 out of 5 lights ....why is so ??? is my battery complaint due to this type of usage ??? can anyone plz give a trouble shoot ////

redDEAD said...

neo,

wash you hands and you battery is probably dead. they don't last forever.

neo said...

read,,,


but if my battery is complaint why its charge at discharge at normal rate !!!! i got an information that may be battery threshhold value is set by 26% that why they dnt recharge more than that !! and if i could charge it 100% once it will be ok !! is there any method to directly charge the battery !!

neo said...

later i searched the web and got information regardng battery recaliberation ...i discrged my battery completely and then charged ........after 2hr i just turn on my system to see any change ..then the battery was nearly 36 % charged and then the same problem occur ..the power doesnt increase ,,.the system show battrey chargirng status ..but no change in 36%..i dischrged the battry again and but no cahge ...it has now 36% battery always ....and the dischrage is noraml when i tried ....
i now think it some problem of battery circiut vales ... help if any know

Aleksey conikarovski said...

I dont even know instal my drivers on Ubuntu. I had XP before and I switch to Ubuntu and Im realy a newbies !! somebody can help me please

redDEAD said...

alek,

All of ubuntu drivers are built into the kernel. Everything works after installation.

Jude said...

my dell inspiron 1501 laptop am encounter some problem; system can't charge the battery each time I start the pc it show the message the battery is in the critical state, I do charge the battery but still remain the same. I chance the adaptor with same specification and even though the battery too. still the same. I recharge the battery from other pc it ok, but the pc itself want the battery. the battery lead indicator remain flashing with the color orange and green. I need to know what's wrong with my pc.


Jude

redDEAD said...

Jude,

It isn't rocket science but it seems to me from your description that your battery is dead.

Jude said...

Change adaptor and battery stil remain the same.

Toggen said...

Hello, it's a late comment...but I just slapped a TL-64 X2 (2.2) Turion in my Dell Inspiron to replace the MK36 (2.0) Turion that came in it. Plus I added another 1 gig stick for a total of 2gigs. It booted without complaint and even changed the AMD Turion logo to the corresponding AMD X2 logo. It runs cooler now than it did. The big lint ball wedged behind the cooling fins didn't help. I cleaned up the cpu and applied Arctic Silver to the cpu before putting it back together. It probably didn't take more than 45 minutes total. I used the Dell service manual to help me. Processor performance in Vista Ultimate (which could really use a reinstall) went from 4.0-4.9, memory went from 4.5-5.5, graphics from 2.2-3.0, and finally gaming from 3.0-3.1. Not too bad for a budget laptop that I bought used. Thanks for listening.

BigPadg said...

Just ordered a Seagate Momentus 160GB 7200rpm sata from NewEgg for $53.99 and the 1.9GHz AMD Turion 64 X2 Mobile TL-58 from www.compuvest.com for $39.99. These to replace my 60GB hard drive and AMD Mobile Sempron 3500+ (1800 real). I'll post again after install with benchmark comparisons.

Echoo Storm said...

I just got the TL-60 to replace my DELL 1501 sempron 3600. I didn't have the manual so I just used basic knowledge on how Laptops are built, plus I took apart my IBook several times now and that is no easy task. Anyways, I didn't upgrade the bios which is at 2.6.2 to the latest as I was too excited about upgrading the cpu. I followed normal procedure, extra carefull handling and Artic Silver. Now when I boot up it sits there at a black screen. Actually the bios doesn't even come up Could it be the fact that I didn't update my Bios? If it is I'll put the old one back update and start over.

Echoo Storm said...

Update: I resolved my own issue. Rechecked everything was properly seated and tried again. Everything came up and I was able to flash the BIOS to the latest version available from DELL. What a difference the new WD Black 250GB 7200rpm and the TL-60 are. It should last me another few years. The 1501 itsef was given to me to fix and the owner gave up on it because of the LCD, replaced that and cleaned it up and it aint bad.

keren_sky said...

@Echoo Storm Can you please provide a link to the site where you purchased the TL60. I want to find a safe site to buy from. Thanks.

shaphier said...

Hi, redDEAD!
I'm using Ubuntu9.10 with my inspiron 1501, but there's a problem about the video driver that's always been offending me since Ubuntu8.04: the Xpress 1150(RS485 IGP) is identified with Xpress 200M(RS482 IGP).What can I do with it?

redDEAD said...

shaphier,

From what I hear certain ATI cards are busted in Ubuntu lately. Have you considered using Fedora?

PLC said...

During a bios update of my DELL 1501 the power was down. Now it doesn't boot. Black screen and caps led flashing. Can somebody help me?
If I remove the coin-cell battery and putted back what I have to do?